Issue with Reports loading
Incident Report for Parking Boss
Resolved
This incident has been resolved.
Posted Jan 02, 2020 - 10:59 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 02, 2020 - 10:48 PST
This incident affected: Reports.