Issue adding new users
Incident Report for Parking Boss
Resolved
This incident has been resolved.
Posted Apr 13, 2020 - 09:40 PDT
Investigating
We are currently investigating this issue.
Posted Apr 13, 2020 - 09:40 PDT
This incident affected: Manager.