Intermittent Errors Creating Guest Permits
Incident Report for Parking Boss
Postmortem

For several hours this evening there were errors creating a small number of permits.

After investigating the error, we’ve identified an update deployed at 2:17 Eastern (11:17 Pacific) incorrectly caused unit numbers that were exactly 22 and 26 characters long to to be incorrectly treated as system IDs, not unit numbers, and when they were processed, it tripped an error. This issue was identified and rolled back.

Fortunately, this only affected about 50 of the nearly 2000 permits created in this time period (54 registrations at 10 communities, only about 2.5% of total registrations in that period).

However, any error like this is unacceptable to us and our customers. We take our reliability incredibly seriously and are very proud of our track record, so we’re putting extra steps in place to make sure nothing like this ever happens again.

If you have any questions or want more details, please don’t hesitate to email us at help@parkingboss.com

-Nathan LeMesurier

Posted 24 days ago. Sep 26, 2019 - 19:49 PDT

Resolved
This incident has been resolved. We've determined only a small number of registrations and communities were affected, please see our postmortem for more information.
Posted 24 days ago. Sep 26, 2019 - 19:48 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted 24 days ago. Sep 26, 2019 - 19:48 PDT
Investigating
We are currently investigating this issue.
Posted 24 days ago. Sep 26, 2019 - 19:48 PDT
This incident affected: Parking Attendant.