Missing access log entries
Incident Report for Community Boss
Postmortem

This morning, we discovered that over the last several days access logs haven't been correctly populated (10/21/2020 - 10/26/2020). After investigating, we discovered the recording process has an error that was tripped by a set of database upgrades, but because this happens in the background, the error wasn't properly tripping our alarms.

We've resolved the underlying bug and validated it's working correctly, but there remains a gap in our access-log coverage. Please rest assured that we log access to Parking Boss via a number of independent methods, so if there's a critical concern about access, please let us know (help@parkingboss.com) and we'll be happy to work with you on it!

We’re really sorry for this and we’re taking every step possible to make sure it never happens again.

Posted Oct 26, 2020 - 08:05 PDT

Resolved
We're investigating reports of missing access log history.
Posted Oct 26, 2020 - 07:58 PDT